Computer Helpline
Working with Images in Photoshop – Part II
By Mike Reed

Intro
In the first part of this series, I showed you how to get started cleaning up and manipulating images in Photoshop. This time we are going to go deeper and touch a wider range of tools that when combined with the techniques taught last time, will enable you to do almost every image manipulation job that you will face. Just remember, Photoshop is a highly mature product and it includes far more tools than you will ever need. Learn just a few primary tools and you will find that you have the power to be extremely effective.
Using Layers

The job of Cutting Out the Background (COB) is one that those tasks that is needed on a regular basis. The right background can take an average photo and turn it into a professional piece. Sometimes removing other people from a group shot can be the difference between being able to use a photo or not.
Before we jump into how to cut out a background, we first need to cover a basic concept of Photoshop known as layers. When we use Photoshop, we are not required to apply paint to every part of the image, so what shows in the areas where we don’t paint? And what if we erase? What shows in the erased areas? Let’s try a couple of quick examples that will answer those question.

Load up your favorite portrait image into Photoshop. Now select the Eraser Tool from the tools palette by clicking the picture of an eraser or by pressing Shift-E.  Now, just below the menus you will see the settings for the eraser. Set the Brush Master Diameter to “10” and the Hardness to “100”. Set the Mode to “Pencil” and the Opacity to 100%. Now start erasing the background portions of your image by left clicking and while holding the mouse button down, move over the portions of the image you wish to erase.
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This is the simplest form of COB. You simply erase the portions of the image you don’t want, in this case the background. You will notice that as you erase, it isn’t really erasing at all, what it’s really doing is painting whatever color you have selected as the background color. To change either the foreground or the background color, you can double click either color. You can also swap the colors using the bent double arrow headed line and you can select the default black foreground and white background by clicking the tiny image just lower left of the color swatches.
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To really have control of the background, you will need to add a layer. You do this by opening the Layers window by pressing F7 or by using the menu Window->Layers. You should see a thumbnail representation of the portrait you opened and the layer will be named “background”. If you don’t see this, then you may need to click the “Layers” tab to view the layers. Once you can see your image layer, click the “Layers Menu” button to open the Layers menu. Now click “New Layer” to create a new layer. You can also press Ctrl-Shift-N to create a new layer above the current layer. Up will pop the New Layer dialog. For now just leave the default settings as-is and click OK to create the new layer.
You can now select layers by clicking on the one you wish to work with. You can only draw on one layer at a time, so always be sure to select the layer you wish to work with before changing the image.

So now let’s work with our new layer. Make sure you have selected the new layer and then set the foreground color to black. Now select the Pencil tool by clicking the pencil icon or pressing Shift-B. Note that there are two tools associated with this area in the tools menu, the Brush tool and the Pencil tool. Click and hold the tool to display all the available tools in that slot, or press Shift-B repetitively until he pencil tool is selected.

Under the menus, you will see the settings for the Pencil tool. Set the Brush Master Diameter to “10” and the Hardness to “100”, just as we did before with the eraser. Now draw a mustache on the person in the portrait. This is just for practice, so you can feel free to do it, if the portrait you chose is of a woman. Don’t worry about it not looking real; this is just to learn about layers, not to learn about drawing mustaches.
Now choose the Move tool by clicking the icon in the tool palette or by pressing Shift-V. Now use the arrow keys on the keyboard and move the mustache around. Note how, because the mustache is on its own layer, it moves independent of the other layer. You can also click and drag on the image to move the contents of the layer around.

The layers are stacked, one on top of another, so that each layer paints over any layers beneath it. You can re-arrange the layers however you like by clicking and dragging a layer up or down in the layers palette. You might notice that you can’t move the “background” layer above other layers nor can you move any layers below the “background” layer.  So for now, you can’t yet rearrange the layers.
Typically the background layer causes more challenges than it solves, so when I start to create layers, the first thing I do is duplicate the background layer by clicking the background layer and selecting “Duplicate Layer” from the layer menu.

Once you have a duplicate of the background, you can delete the background layer by selecting it and then using the “Delete Layer” function in the layer menu. Now that you have eliminated the background layer and replaced it with a duplicate layer that is a regular layer, you can change the order of the layers by clicking and dragging them to whatever order you need.

Earlier we used the eraser to remove the background of our portrait, but if you recall, it didn’t remove the background, instead it painted the selected background color. But now that we have converted our portrait to a “real” layer, instead of being the “background” layer, things work a little differently.

Let’s repeat our exercise from before. Make sure you have the portrait layer selected, and then select the Eraser Tool from the tools palette by clicking the picture of an eraser or by pressing Shift-E.  Now, just below the menus you will see the settings for the eraser. Set the Brush Master Diameter to “10” and the Hardness to “100”. Set the Mode to “Pencil” and the Opacity to 100%. Now start erasing the background portions of your image by left clicking and while holding the mouse button down, move over the portions of the image you wish to erase. Same steps as before, but do you see the difference? Now as you erase, transparency is the result. (Yes, the grey and white checkerboard means transparent)
To see this more clearly, create a new layer by pressing Ctrl-Shift-N. Now use the menus and select Edit->Fill or press Shift-F5 to open the fill dialog. In the content area, open the dropdown and select Color. Then choose a bright color. Set the Blending mode to Normal and the Opacity to 100. The result should be a bright color filling the image with the mustache visible on top of it.

Now drag the new layer under the portrait layer and you will now see that the mustache layer is on top of the portrait layer and below that is the bright colored layer we just created. If you don’t see the bright colored layer at all, then you didn’t erase any of the portrait image. So select the eraser and then select the portrait layer and start erasing the background. You’ll notice now that as you erase, what you erase is replaced with the bright background that we created.
Now this background could have been anything we wanted to put on the layer below the portrait. You can get backgrounds from professional stock imagery websites like www.comstock.com or www.gettyimages.com or you can use images.google.com for free images. A few nice backgrounds can go a long way. You don’t need hundreds or thousands of backgrounds, a few nice ones will work over and over again. You can also play with the Filter menu in Photoshop to create one of your own.

Let me add one last note on using layers. Beside each layer is a picture of an eye. Clicking the eye toggles it on and off. When the eye is visible, the contents of the layer are drawn in the image, but when it is not visible, the contents of the layer not drawn. The layer still remains in the Layers palette, but it’s contents are hidden in the image. This can be very powerful for viewing a single layer or a specific set of layers. Remember, you can have as many layers as you like up to the amount of memory (RAM) in your computer.
There is an endless amount that I could teach you about using layers, but what I’ve shown here will help to get you started and give you all you need to know for a wide range of tasks. Now that you know about layers, it’s time to once again talk about cutting out backgrounds.

Cutting Out Backgrounds (COB)
As we have learned above, you can use the eraser to cut out backgrounds, but this is a very rough and difficult way to get the job done. There are two other techniques that are much more widely used. They are the Extract Tool, which is the easiest and fastest way to do a COB, and the Pen Tool which is the most controlled and most commonly used approach. I will teach you to use both.

Before we can perform a COB, we need a picture and a replacement background. So first close the portrait image that we have been working with up to this point and do not save any changes that we made. Now reload the same portrait as before. Notice that once again it loads as the background layer, so duplicate the layer and delete the original background. 

To create a simple background, we will use a version of the original image. So duplicate the layer once again so that you have two layers, each containing the portrait. Now select the top layer and use the Filter->Blur->Gaussian Blur filter with the slider in about the middle to get a very blurry effect. This will cause the top layer to get very blurry, concealing the fact that it was derived from the original photo and give us a background that is a natural fit to the original portrait. Ok, so it’s not as nice as a purchased background, but it was fast, easy and free. 

You can purchase professional backgrounds or even use free images from the Internet, but for now, we will just use the free and easy to create blurred version of our original. Either way you go, you will need to drag the background layer below the portrait layer. This will initially hide the background layer under our portrait layer until we tell Photoshop which portions of the portrait to cut away so that the background can show through.
The Extract Tool
There is a built in tool designed specifically to cut out backgrounds. It is called the Extract Tool. To use it select the layer that contains the portrait and then use the menus to select Filter->Extract or you can press Alt-Ctrl-X on the keyword. Either method will open the Extract Tool dialog.
There are a lot of controls on this dialog, but you need only a few of them to get the basic job done. First, set the brush size to 10 and check the Smart highlighting checkbox. Now click the magnifying glass on the left side of the dialog and drag a rectangle around where the edge between the portions of the portrait that you wish to keep the portions of the background you want to remove is very obvious. This will zoom into the image to that location. Use the mouse, left click and draw a line where half the width of the line covers the portrait that you want to keep and half covers the background that you wish to cut away. Do this around the entire image, using the Space Bar to activate the Hand Tool, to allow you to drag new portions of the image into the work area. You can start and stop as often as needed, but the green line must be solid, with no breaks and if you hit the edge of the picture, draw along it as well. When you are finished, you need to have created a green border all the way around the portion of the image you wish to keep. If there are gaps, the next step will fail.
Once you have defined the border, switch to the Fill Tool by clicking the bucket icon or using Shift-G on the keyboard. Now click inside the area you wish to keep and it will be filled with a transparent blue color. If it looks good, click OK.

If you notice that the Extract Tool cut away portions of the image you wanted to keep, or left portions of the image that you wanted cut away, then it’s because you didn’t define the edge correctly. Use Undo, which you can find in the menus as Edit->Undo or Ctrl-Z on the keyboard, and try again. I told you to use a diameter of 10, but that isn’t always the best setting. You want to use the smallest setting you can, while still being able to define a line that is half on the portrait and half on the background. Select too small a diameter and Photoshop will fail to estimate the edge correctly because there isn’t enough of each side to help define the edge. Select a brush that is too large and the edge will be soft, ragged or undefined because Photoshop has too many choices when trying to find the edge and it will make mistakes.
The extract tool is incredibly powerful, but it’s not how most professionals do a COB. The edge just isn’t fine enough for some people. As quick and easy as it is to use, it’s worth trying first and then if the results are not satisfactory, use the Pen Tool for a perfect COB.
The Pen Tool
If you want ultimate control over your COB, then this is the tool to use. This tool allows you to draw the outline between the portion of the image to save and the portion of the image to remove with any level of detail needed. There are many ways to use the tool, so you may read of ways that differ from what I’m about to teach you, but as long as it works, any method is fine. They all have advantages and disadvantages.

Close the image once again, and don’t save it. Now reload it, and as before, duplicate the background and then delete the background layer. Create a second duplicate and blur it as before. Move the blurred layer below the main layer. Now you’re ready to start. Are you starting to get the hang of using layers? Hang in there, it gets easer with more practice.
Click the Pen tool in the tools palette; it looks like the head of a calligraphy pen, or press Shift-P on the keyboard. Now zoom into the image where the edge is clearly defined and left click on the edge. Normally there is a fringe between the person and the background. As a rule of thumb, I put the points just inside that fringe. Now click along the border, but be sure that you don’t go too far with each click as the dots are connected with straight lines, so the closer the dots the better the edge will look. As long as you are zoomed in, and you don’t space the dots too far apart, and you always click just inside the fringe, you will get a great COB.
If you make a mistake, then use the Backspace key to undo the last point, or use Step Backwards, Ctrl-Alt-Z, to undo as many points as it takes to return to a correct point. Continue around the edge until you have completely defined the area to keep. When you get close to the place where you started, place the mouse pointer over the first point and you will see a small circle. This tells you that you are about to close the loop and create a shape. Click and a shape will be created.

Now that you have a shape that exactly covers the person in the portrait, you need to cut away the rest of the image. Select the new shape layer that you just created and then right click on that layer. This will open a context menu for the layer and you can select to Rasterize the Layer. What this does is convert the shape to pixels. Once that is done, choose the Magic Wand Tool by clicking it or by pressing Shift-W on the keyboard. Now click on the newly created rasterized shape. You now have a selection that is the same shape as the area you want to keep, but we need to delete all but that part of the image, so we need to invert the selection. To do this you can use the menu Select->Inverse or use the keyboard by pressing Shift-Ctrl-I.
We are very close now. We can click the eye on the rasterized layer to hide it and then select the image layer. Once this is done, all that is left to do is press the Delete key. Well, there you have it, a very nice COB with a blurred background ready for use. Once you get good at this procedure, depending on the complexity of the image, it will take you between 10 and 30 minutes to COB any portrait and create a useable image. 
Close
The tools I showed you today build well on those I have shown you in previous articles. They will empower you to create professional, personalized materials for your customers.  The reason I keep covering Photoshop is that its value in a funeral home is great. Having one or more people on-staff that know how to harness its power can dramatically add to your bottom line. If there are other topics that you’d like to see covered, Photoshop related or not, write to me. I’d love to answer your questions, hear your feedback and respond to your suggestions. It is my goal to help you unlock the power that is just sitting idle in your computer.
Mike Reed is a 27 year veteran of the computer industry having developed a large number of commercial and industrial applications. See his project at http://RememberedByUs.com where you can set up free Internet Memorials. Contact Mike if you are interested in adding information about your funeral home to the memorials you set up. You can email Mike with questions or comments at mr.afd@up1.com. 
